Metatrader Forum | Forex Expert-Advisor | Broker & Forex Tools  
Zurück   Metatrader Forum | Forex Expert-Advisor | Broker & Forex Tools > Metatrader 4 > Programmierung MQL4

Programmierung MQL4 Hier gehts rund ums Programmieren in MQL4.

Login
Benutzername:
Kennwort:


Statistik
Themen: 4294
Beiträge: 39577
Benutzer: 6.607
Aktive Benutzer: 218
Links: 80
Wir begrüßen unseren neuesten Benutzer: Carstn
Mit 1.311 Benutzern waren die meisten Benutzer gleichzeitig online (vor 5 Tagen um 01:18).
Neue Benutzer:
vor 3 Stunden
- Carstn
vor 6 Tagen
- dellinger
vor einer Woche
- SABA
vor einer Woche
- artfeld
vor einer Woche
- sonnejian

Onlineuser
'Wer ist online' anzeigen Benutzer: 0
Gäste: 153
Gesamt: 153
Team: 0
Team:  
Benutzer:  
Freunde anzeigen

Empfehlungen

Thema geschlossen
 
Themen-Optionen Thema durchsuchen Ansicht
  #1 (permalink)  
Alt 21.11.18
Neues Mitglied
 
Registriert seit: Sep 2011
Beiträge: 29
derumuro befindet sich auf einem aufstrebenden Ast
Standard Älteren EA reparieren

Hallo Zusammen,

ich habe einen EA, der noch nach den älteren Regeln von MQL4 programmiert wurde.
Beim Kompilieren meldet mir der Editor jetzt 176 Fehler.

Kann mir jemand der EA reparieren?

Vorab schon mal Danke!
  #2 (permalink)  
Alt 22.11.18
Mitglied
 
Registriert seit: Jun 2011
Ort: Minsk, Weißrussland
Beiträge: 69
Bobs befindet sich auf einem aufstrebenden Ast
Standard

Natürlich ist es möglich, aber es braucht Zeit und Mühe.
  #3 (permalink)  
Alt 23.11.18
Neues Mitglied
 
Registriert seit: Sep 2011
Beiträge: 29
derumuro befindet sich auf einem aufstrebenden Ast
Standard

Das dachte ich mir auch schon, daß das Zeit kostet. Für einen Profi sollte es jedoch kein Problem sein.
  #4 (permalink)  
Alt 24.11.18
Mitglied
 
Registriert seit: Jun 2011
Ort: Minsk, Weißrussland
Beiträge: 69
Bobs befindet sich auf einem aufstrebenden Ast
Standard

Suchen Sie jemanden gegen Geld zu tun, oder nur Beratung?
  #5 (permalink)  
Alt 24.11.18
Neues Mitglied
 
Registriert seit: Sep 2011
Beiträge: 29
derumuro befindet sich auf einem aufstrebenden Ast
Standard

Was meinen Sie mit Beratung?
  #6 (permalink)  
Alt 24.11.18
Mitglied
 
Registriert seit: Jun 2011
Ort: Minsk, Weißrussland
Beiträge: 69
Bobs befindet sich auf einem aufstrebenden Ast
Standard

Ich meine Konsultation/Diskussion, um selbst alles zu reparieren.
  #7 (permalink)  
Alt 25.11.18
Neues Mitglied
 
Registriert seit: Sep 2011
Beiträge: 29
derumuro befindet sich auf einem aufstrebenden Ast
Standard

Ja, das wäre eine Möglichkeit.
  #8 (permalink)  
Alt 26.11.18
Elite Mitglied
 
Registriert seit: Sep 2015
Beiträge: 782
MA-EA befindet sich auf einem aufstrebenden Ast
Standard

Lad mal hoch. Irgendwer wird schon helfen können.
  #9 (permalink)  
Alt 26.11.18
Neues Mitglied
 
Registriert seit: Sep 2011
Beiträge: 29
derumuro befindet sich auf einem aufstrebenden Ast
Standard

Ich habe jetzt die meisten Fehler behoben. Folgende sind noch übrig:

Am Anfang des EAs habe ich eine Variable definiert: double a;
Beim Aufruf der Variable in: void b(double a) bekomme ich die Fehlermeldung:
declaration of 'a' hides global declaration.
Wenn ich das "double" weg lasse, kommt folgende Meldung:
expressions are not allowed on a global scope.

Was ist falsch?
  #10 (permalink)  
Alt 26.11.18
Mitglied
 
Registriert seit: Jun 2011
Ort: Minsk, Weißrussland
Beiträge: 69
Bobs befindet sich auf einem aufstrebenden Ast
Standard

Vielleicht haben Sie "#property strict" und double a leigt in Bereich if(...){double a; ...} ?
Thema geschlossen

Lesezeichen


Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are aus
Pingbacks are aus
Refbacks are aus




Alle Zeitangaben in WEZ +2. Es ist jetzt 01:21 Uhr.


Der Wavesnode - Spam Firewall
-----------------------------------------------------------------------------------------------------------------------------
Powered by vBulletin® Version 3.8.5 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by vBCMS® 2.7.0 ©2002 - 2019 vbdesigns.de
SEO by vBSEO 3.6.1
Copyright ©2009 - 2017 by Expert-Advisor.com - Das Metatrader Forum
MetaTrader bzw. MetaTrader 4 und MetaTrader 5 sind eingetragene Marken der MetaQuotes Software Corp.
-----------------------------------------------------------------------------------------------------------------------------