Metatrader Forum | Forex Expert-Advisor | Broker & Forex Tools  
Zurück   Metatrader Forum | Forex Expert-Advisor | Broker & Forex Tools > Metatrader 4 > Programmierung MQL4

Programmierung MQL4 Hier gehts rund ums Programmieren in MQL4.

Login
Benutzername:
Kennwort:


Statistik
Themen: 4396
Beiträge: 40167
Benutzer: 6.771
Aktive Benutzer: 229
Links: 80
Wir begrüßen unseren neuesten Benutzer: Pierrot1505
Mit 2.475 Benutzern waren die meisten Benutzer gleichzeitig online (16.01.20 um 22:38).
Neue Benutzer:
vor 15 Stunden
- Pierrot150...
vor einem Tag
- doanabogda...
vor 3 Tagen
- mausgamble...
vor 5 Tagen
- dr.o.kilic...
vor 6 Tagen
- harabaader

Onlineuser
'Wer ist online' anzeigen Benutzer: 2
Gäste: 194
Gesamt: 196
Team: 0
Team:  
Benutzer:  traderdoc
Freunde anzeigen

Empfehlungen

Antwort
 
Themen-Optionen Thema durchsuchen Ansicht
  #1 (permalink)  
Alt 05.02.20
AVT AVT ist offline
Mitglied
 
Registriert seit: Mar 2018
Ort: Hamburg
Beiträge: 279
AVT befindet sich auf einem aufstrebenden Ast
Standard "Berechnungsloch" im VWAP

Den VWAP gibt's nich in der MT4 Bibliothek, also hab ich mir die Formel besorgt und das selbst gemacht. Da habe ich aber ein Problem, bei dem ich NULL Ahnung habe, woran es liegen könnte.

Berechnung erfolgt folgendermaßen:
1. Sobald einen neue Periode anfängt, werden alle Werte auf Null gesetzt
2. Loop über den Berechnungszeitraum mit Berechnung
3. Painting über Buffer im selben Zeitraum
Code:
// === between start and stop time calc values
if(   Time[i]>=StrToTime(iday+" "+DayStartTime)     //09:00 local
   && Time[i]<=StrToTime(iday+" "+DayStopTime)  )   //17:30 local
{ // === calculation }
Daran gibt es nix zu rütteln, aber gegen Ende gibt es ein Kerze (die in der Mitte, die keinen Berechnungswert hat! (Bild anbei). Daran, daß die Werte zu hoch sind, kann es nicht liegen, erstens sind sie double und zweitens sind die nächsten Werte ja noch höher (nach Formel).

Hat jemand eine Idee? AVT
Angehängte Grafiken
Dateityp: jpg VWAPloch.JPG (16,3 KB, 5x aufgerufen)

Geändert von AVT (05.02.20 um 22:06 Uhr) Grund: Bild vergessen anzuhängen
Mit Zitat antworten
  #2 (permalink)  
Alt 06.02.20
Elite Mitglied
 
Registriert seit: Sep 2015
Beiträge: 897
MA-EA befindet sich auf einem aufstrebenden Ast
Standard

Gap?
Mit Zitat antworten
Antwort

Lesezeichen


Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are aus
Pingbacks are aus
Refbacks are aus




Alle Zeitangaben in WEZ +2. Es ist jetzt 22:10 Uhr.


Der Wavesnode - Spam Firewall
-----------------------------------------------------------------------------------------------------------------------------
Powered by vBulletin® Version 3.8.5 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by vBCMS® 2.7.0 ©2002 - 2020 vbdesigns.de
SEO by vBSEO 3.6.1
Copyright ©2009 - 2017 by Expert-Advisor.com - Das Metatrader Forum
MetaTrader bzw. MetaTrader 4 und MetaTrader 5 sind eingetragene Marken der MetaQuotes Software Corp.
-----------------------------------------------------------------------------------------------------------------------------